[git-buildpackage] setting author on command line for gbp dch

Nish Aravamudan nish.aravamudan at canonical.com
Mon Dec 18 09:18:27 CET 2017

On Dec 18, 2017 13:40, "Gijs Molenaar" <gijsmolenaar at gmail.com> wrote:

2017-12-18 9:35 GMT+02:00 Gijs Molenaar <gijsmolenaar at gmail.com>:

> Hi Guido,
> Thanks for your reply, and sorry for the delay.
> 2017-11-27 15:30 GMT+02:00 Guido Günther <agx at sigxcpu.org>:
>> [...]
>> This works as exected in 0.9.3 and in 0.8.18:
>>     DEBFULLNAME="bla fasel" gbp dch -S -a --no-git-author -Dxenial
> I'm trying to clone the repository from https://git.sigxcpu.org/c
> git/git-buildpackage/ but it just seems
> to hang (Cloning into 'git-buildpackage'...without any progress) . I also
> tried to checkout only one branch.
> I can visit the web interface without problems though.

Ok I was too impatient, sorry about that. I'm not sure why but git was not
giving any feedback. After a while the repo was
just cloned. It works now! In case you are curious, what I did:

0.8.18 seems to depend on devscripts (>= 2.17.7~) which itself also depend
on packages that
should probably require a backport. That becomes to much work. If change
the dependency to (devscripts 2.16.2).
Then the test suite fails:

gbp: debug: ['git', 'rev-parse', '--show-cdup']
gbp: debug: ['git', 'rev-parse', '--is-bare-repository']
gbp: debug: ['git', 'rev-parse', '--git-dir']
gbp: debug: /usr/bin/pristine-tar [] ['verify',
gbp: error: Pristine-tar couldn't verify "upstream_1.0.orig.tar.gz":
pristine-tar: Unknown subcommand "verify"

You need a more recent pristine-tar than what is in 16.04, iirc.

I noticed there is a DEB_BUILD_OPTIONS=nocheck option, but that doesn't
seem to work for me, if I run:

DEB_BUILD_OPTIONS=nochecks dpkg-buildpackage

it still runs the test suite. If i disable the test suite manually in
debian/control the package builds! If i instal
 it the signature is correctly updated. thanks!

If you want to file a bug in Ubuntu and subscribe me, I can help backport
this change.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sigxcpu.org/pipermail/git-buildpackage/attachments/20171218/b853658e/attachment-0001.html>

More information about the git-buildpackage mailing list